TaxCaddy Outage
Incident Report for TaxCaddy
Resolved
The issues causing the “Oops” page have been resolved.
Posted Jun 05, 2019 - 10:21 PDT
Investigating
Some customers are reporting an “Oops” page when trying to access TaxCaddy. We are working to identify the cause and resolve the issue immediately. Updates will be posted here as we get them.
Posted Jun 05, 2019 - 08:24 PDT
This incident affected: TaxCaddy Web Portal.