Incident report
Incident Report for TaxCaddy
Resolved
The Amazon S3 throttling errors that caused the TaxCaddy connectivity issues have been resolved and services are now operating normally.
Posted over 1 year ago. Sep 14, 2017 - 13:32 PDT
Investigating
We're investigating reports of TaxCaddy connectivity issues. Customers are reporting errors when trying to log in to TaxCaddy. Incident updates will be posted here as we get them.
Posted over 1 year ago. Sep 14, 2017 - 12:36 PDT