New users receive "Oops" page when attempting to log in
Incident Report for TaxCaddy
Resolved
The "Oops" page issue has been resolved.
Posted 11 months ago. Apr 16, 2018 - 17:18 PDT
Identified
TaxCaddy users of accounts created since midnight 4/15/2018 receive an "Oops" page when attempting to log in. We are working to resolve the issue immediately. Incident updates will be posted here.
Posted 11 months ago. Apr 16, 2018 - 13:05 PDT