Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 31, 2024 - 00:30 PDT
Scheduled
TaxCaddy will undergo the following maintenance period:
12:30 AM Pacific on Friday, May 31 to 3:30 AM Pacific on Friday, May 31. Customers will be unable to connect during this 3 hour maintenance period. We schedule maintenance at times that minimize the impact to our customers but we apologize for any inconvenience.
Posted May 20, 2024 - 10:41 PDT
This scheduled maintenance affected: TaxCaddy Browser-based Portal, TaxCaddy App for iOS, and TaxCaddy App for Android.