Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 16, 2023 - 00:00 PDT
Scheduled
TaxCaddy will undergo the following maintenance period:
12:00 AM to 2:00 AM Pacific on Friday, June 16. Customers will be unable to connect during this 2-hour maintenance period. We schedule maintenance at times that minimize the impact to our customers but we apologize for any inconvenience.
Posted Jun 08, 2023 - 12:50 PDT
This scheduled maintenance affected: TaxCaddy Browser-based Portal, TaxCaddy App for iOS, TaxCaddy App for Android, TaxCaddy Email Notifications, and TaxCaddy Two-Factor Authentication.