Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 14, 2024 - 21:00 PST
Scheduled
TaxCaddy will undergo the following maintenance period:
09:00 PM Pacific on Thursday, November 14 to 01:00 AM Pacific on Friday, November 15. Customers will be unable to connect during this 4 hour maintenance period. We schedule maintenance at times that minimize the impact to our customers but we apologize for any inconvenience.
Posted Nov 07, 2024 - 05:29 PST
This scheduled maintenance affected: TaxCaddy Browser-based Portal, TaxCaddy App for iOS, TaxCaddy App for Android, and TaxCaddy Tax Pro Dashboard.