Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 17, 2023 - 19:30 PST
Scheduled
TaxCaddy will undergo the following maintenance period:
7:30 PM Pacific on Sunday, December 17 to 11:30 PM Pacific on Sunday, December 17. Customers will be unable to connect during this 4 hour maintenance period. We schedule maintenance at times that minimize the impact to our customers but we apologize for any inconvenience.
Posted Dec 11, 2023 - 14:48 PST
This scheduled maintenance affected: TaxCaddy Browser-based Portal, TaxCaddy App for iOS, TaxCaddy App for Android, TaxCaddy Email Notifications, TaxCaddy Two-Factor Authentication, and TaxCaddy Tax Pro Dashboard.