TaxCaddy Oops Message
Incident Report for TaxCaddy
Resolved
The TaxCaddy Oops message issue has been resolved. If the system status changes, updates will be posted here: https://status.taxcaddy.com.
Posted Jan 30, 2023 - 16:10 PST
Investigating
Some customers are reporting an "Oops" error message. Our engineers are investigating. Incident updates will be posted here: https://status.taxcaddy.com
Posted Jan 30, 2023 - 13:56 PST
This incident affected: TaxCaddy Browser-based Portal, TaxCaddy App for iOS, and TaxCaddy App for Android.